华为交换机:支持端口重定向功(traffic-redirect inbound acl)(证明此实验中弱三层不支持,原因三层接口的mac地址一样)真机可以,只是抓流量方面有点问题,暂不清楚原因。

华为交换机:支持端口重定向功(traffic-redirect inbound acl)(证明此实验中弱三层不支持,原因三层接口的mac地址一样)真机可以,只是抓流量方面有点问题,暂不清楚原因。

[Switch] acl 3000
[Switch-acl-adv-3000] rule 0 permit ip source 192.168.0.0 0.0.0.255
[Switch-acl-adv-3000] quit
[Switch] interface G1/0/0
[Switch-Ethernet1/0/6]   traffic-redirect inbound acl 3000 ip-nexthop 192.168.11.254

[Switch-Ethernet1/0/6] quit
(1)拓扑图

图片.png

(2)基本配置

sw1:
vlan batch 2 6 11 22
interface Vlanif1
 ip address 192.168.1.1 255.255.255.0
#
interface Vlanif2
 ip address 172.16.1.1 255.255.255.0
#
interface Vlanif6
 ip address 1.1.1.1 255.255.255.0
#
interface Vlanif11
 ip address 192.168.11.1 255.255.255.0
#
interface Vlanif22
 ip address 192.168.22.1 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 11                     
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 22
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 2
#
interface GigabitEthernet0/0/4
#
interface GigabitEthernet0/0/5
#
interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 6
ip route-static 0.0.0.0 0.0.0.0 1.1.1.254

sw2:
vlan batch 6
interface Vlanif6
 ip address 1.1.1.254 255.255.255.0
interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 6
interface LoopBack1
 ip address 2.2.2.2 255.255.255.255
#
ip route-static 0.0.0.0 0.0.0.0 1.1.1.1

测试:

图片.png

此时的流量走向:

图片.png

(3)配置重定向

acl number 3000
 rule 10 permit ip source 192.168.1.0 0.0.0.255
interface GigabitEthernet0/0/4
 traffic-redirect inbound acl 3000 ip-nexthop 192.168.11.254

测试:

图片.png

抓包:

图片.png

图片.png

流量都没有从R1的g0/0/1接口发出去。

流量走向:

图片.png

此时,R1是可以ping通2.2.2.2的

图片.png

图片.png

PC1 ping 192.168.1.1的流量也都被重定向到R1那里了。

图片.png

(4)修改后再测试

acl number 3002
 rule 10 permit ip source 192.168.1.0 0.0.0.255 destination 2.2.2.2 0
 rule 20 deny ip    
interface GigabitEthernet0/0/4
 traffic-redirect inbound acl 3002 ip-nexthop 192.168.11.254

图片.png

保存配置,重启所有设备再测试:所有的流量都最不往R1那边走,关闭了实验,再打开实验还是一样的结果。

图片.png


修改后再测试:

acl number 3000
 rule 3 deny ip destination 223.6.6.6 0
 rule 5 deny ip source 192.168.1.0 0.0.0.255 destination 192.168.1.1 0
 rule 10 permit ip source 192.168.1.0 0.0.0.255

interface GigabitEthernet0/0/4
 traffic-redirect inbound acl 3002 ip-nexthop 192.168.11.254

图片.png

把实验关闭再打开,又全通了。223.5.5.5不通正常,因为没有接外网。

图片.png

图片.png

[sw1]int GigabitEthernet 0/0/4
[sw1-GigabitEthernet0/0/4]undo traffic-redirect inbound acl 3000
[sw1-GigabitEthernet0/0/4]
[sw1-GigabitEthernet0/0/4] traffic-redirect inbound acl 3000 ip-nexthop 192.168.11.254

图片.png

接口重新配置重定向后就生效了。

但所有的流量都往往R1走了。

图片.png

不知道是不是模拟器的问题,所以找真机来测试下。

华为交换机:配置策略路由引流到旁挂设备问题
http://www.zh-cjh.com/luyoujiaohuan/1913.html


找真机来测试:

sw1_2022.10.23.16时44分20秒.txt

sw2_2022.10.23.16时44分58秒.txt

sw3_2022.10.23.16时45分28秒.txt

(1)拓扑图

图片.png

(2)基本配置

sw1:
vlan batch 2 6
interface Vlanif2
 ip address 172.16.1.1 255.255.255.0
#
interface Vlanif6
 ip address 1.1.1.1 255.255.255.0
interface GigabitEthernet0/0/1
 undo portswitch
 ip address 192.168.11.1 255.255.255.0
#
interface GigabitEthernet0/0/2
 undo portswitch
 ip address 192.168.22.1 255.255.255.0
#
interface GigabitEthernet0/0/3            
 port link-type access
 port default vlan 2
#
interface GigabitEthernet0/0/4
 undo portswitch
 ip address 192.168.1.1 255.255.255.0
#
interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 6
ip route-static 0.0.0.0 0.0.0.0 1.1.1.254

sw2:
vlan batch 6
interface Vlanif6
 ip address 1.1.1.254 255.255.255.0
interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 6
interface LoopBack1
 ip address 2.2.2.2 255.255.255.255
interface LoopBack2
 ip address 3.3.3.3 255.255.255.255
ip route-static 0.0.0.0 0.0.0.0 1.1.1.1

sw3:
vlan batch 11 22
interface Vlanif11
 ip address 192.168.11.254 255.255.255.0
#
interface Vlanif22
 ip address 192.168.22.254 255.255.255.0
#                                         
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 22
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 11
ip route-static 0.0.0.0 0.0.0.0 192.168.22.1
ip route-static 192.168.1.0 255.255.255.0 192.168.11.1

图片.png

图片.png

(3.1)配置重定向 (pnig 2.2.2.2与3.3.3.3都不通)

sw1:

acl number 3001
 rule 10 permit ip source 192.168.1.0 0.0.0.255
 
interface GigabitEthernet0/0/4
 traffic-redirect inbound acl 3001 ip-nexthop 192.168.11.254

图片.png

按理不会有路由环由,找到了原理,是在全局上配置了这条命令,这条命令不仅可以在接口上配置,也可以在全局上配置。

 traffic-redirect inbound acl 3001 ip-nexthop 192.168.11.254

图片.png

删除这条命令的全局配置后再测试就正常了。

[sw1]undo traffic-redirect inbound acl 3001

图片.png

图片.png

(4.1)修改重定向的ACL

sw1:
acl number 3000
 rule 3 deny ip destination 3.3.3.3 0
 rule 5 deny ip source 192.168.1.0 0.0.0.255 destination 192.168.1.1 0
 rule 10 permit ip source 192.168.1.0 0.0.0.255
interface GigabitEthernet0/0/4
 traffic-redirect inbound acl 3000 ip-nexthop 192.168.11.254

图片.png

重启sw1交换机后,结果还是如上图所示。不知道为什么把所有流量都往sw3发。

(4.2)修改重定向的ACL

acl number 3000
 rule 3 deny ip destination 3.3.3.3 0
 rule 5 deny ip source 192.168.1.0 0.0.0.255 destination 192.168.1.1 0
 rule 10 deny ip

interface GigabitEthernet0/0/4
 traffic-redirect inbound acl 3000 ip-nexthop 192.168.11.254

图片.png

重启sw1交换机后,结果还是如上图所示。不知道为什么把所有流量都往sw3发。

(4.3)修改重定向的ACL

acl number 3000
 rule 1 deny ip source 192.168.1.0 0 destination 2.2.2.2 0
 rule 3 deny ip destination 3.3.3.3 0
 rule 5 deny ip source 192.168.1.0 0.0.0.255 destination 192.168.1.1 0
 rule 10 deny ip
interface GigabitEthernet0/0/4
 traffic-redirect inbound acl 3000 ip-nexthop 192.168.11.254

图片.png

重启sw1交换机与PC1后,结果还是如上图所示。不知道为什么把所有流量都往sw3发。

(5.1)使用pbr做重定向

acl number 3000
 rule 3 deny ip destination 3.3.3.3 0
 rule 5 deny ip source 192.168.1.0 0.0.0.255 destination 192.168.1.1 0
 rule 10 permit ip source 192.168.1.0 0.0.0.255
 
traffic classifier c1 operator and
 if-match acl 3000
traffic behavior b1
 redirect ip-nexthop 192.168.11.254
#                                         
traffic policy p1
 classifier c1 behavior b1

interface GigabitEthernet0/0/4
 traffic-policy p1 inbound

图片.png

图片.png

相关文章:

华为交换机:配置策略路由引流到旁挂设备问题
http://www.zh-cjh.com/luyoujiaohuan/1913.html

(6.1)把弱三层的交换机放到sw1的位置,原因是弱三层交换要的vlanif接口的mac地址都一样,因为eNSP模拟器上的流量没有继续转发,看下真机是不是也这样?

图片.png

sw1:

acl number 3000
 rule 3 deny ip destination 3.3.3.3 0
 rule 5 deny ip source 192.168.1.0 0.0.0.255 destination 192.168.1.1 0
 rule 10 permit ip source 192.168.1.0 0.0.0.255
#                                         
traffic classifier c1 operator and
 if-match acl 3000
#
traffic behavior b1
 redirect ip-nexthop 192.168.11.254
#
traffic policy p1
 classifier c1 behavior b1
interface GigabitEthernet0/0/4
 port link-type access
 port default vlan 4
 traffic-policy p1 inbound

sw1_2022.10.23.17时39分08秒.txt

sw2_2022.10.23.17时40分00秒.txt

sw3_2022.10.23.17时40分30秒.txt

图片.png


华为路由器:配置策略路由引流到旁挂设备问题(重定向)
http://www.zh-cjh.com/luyoujiaohuan/3327.html

结论:此拓扑中,弱三层交换机不支持重定向,可能是因为三层接口的mac地址一样,换成路由器或者增强版的交换机就可以。

QoS服务质量(列表、list、全)qoslist

http://www.zh-cjh.com/wenzhangguilei/2180.html

文章归类、所有文章列表、LISTLIST
http://www.zh-cjh.com/wangzhangonggao/2195.html


1、本站资源长期持续更新。
2、本资源基本为原创,部分来源其他付费资源平台或互联网收集,如有侵权请联系及时处理。
3、本站大部分文章的截图来源实验测试环境,请不要在生产环境中随意模仿,以免带来灾难性后果。

转载请保留出处:  www.zh-cjh.com珠海陈坚浩博客 » 华为交换机:支持端口重定向功(traffic-redirect inbound acl)(证明此实验中弱三层不支持,原因三层接口的mac地址一样)真机可以,只是抓流量方面有点问题,暂不清楚原因。

作者: cjh


手机扫一扫,手机上查看此文章:

一切源于价值!

其他 模板文件不存在: ./template/plugins/comment/pc/index.htm

未雨绸缪、居安思危!

数据安全、有备无患!

注意操作、数据无价!

一切源于价值!